Erreur de version de Dart

Bonjour,
Aujourd’hui je n’arrive plus à compiler mes projets, vscode m’envoie des erreurs liées à la version de dart et en regardant sur le web, je n’ai pas réussi à résoudre le problème.
Voici les erreurs

lib/main.dart: Warning: Interpreting this as package URI, ‹ package:interastion2/main.dart ›.

…/…/…/flutter/packages/flutter/lib/material.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/about.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/animated_icons.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/app.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/app_bar.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/app_bar_theme.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/arc.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/autocomplete.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/back_button.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

^

…/…/…/flutter/packages/flutter/lib/src/material/banner.dart:1:1: Error: The specified language version is too high. The highest supported language version is 2.11.

// Copyright 2014 The Flutter Authors. All rights reserved.

Apparemment dans mon application, il demande de compiler avec dart 2.12

Bonjour @Ved , ça peut être un problème de configuration ou tout simplement un problème interne à flutter suite à une mise à jour.
Commence par executer la commande suivante dans ton projet : flutter clean, puis recommence ta compilation pour voir si le problème persiste.

J’ai effacé le dossier caché .vscode et j’ai redémarré vscode en réinstallant le plugin flutter et tout est rentré dans l’ordre (30h de perdues à chercher ça).
(je suis sous Linux Mint)
Résolu !

1 J'aime