Pdf Modifiable,package obsolète pour Flutter 2.6.0

Bonjour,

Je voudrais pouvoir mettre des PDF interactifs/modifiable mais cependant les seuls packages que j’ai trouvée son malheureusement obsolète à la nouvelle version de Flutter(2.6.0).

Merci d’avance pour ceux qui prendrons le temps de m’aider.

Connaissez-vous des packages plus récents?

Ajouter un éditeur de PDF semble être une tâche complexe et j’aurais très peur de confier ça à une librairie externe, surtout si elle n’est plus à jour.
Personnellement je me suis posé la question de l’affichage de PDF dans mon app de Purple Giraffe et après avoir testé un ou 2 modules externes j’avais déjà des soucis de compatibilité sur certains pdf. Je n’ose même pas imaginer pour l’édition.

Finalement j’ai choisi de déléguer cette tâche au système ou aux autres applications : dès qu’un fichier de type PDF est présent dans l’app, je le télécharge en local, puis si l’utilisateur veut l’ouvrir je lui propose le volet de partage système qui liste ses apps compatibles avec les PDF (ça inclut les fonctions système de lecture et annotation de PDF).

J’ai utilisé share_plus pour afficher ce volet

Voici à quoi ça ressemble sur un iPhone :

1 « J'aime »

Pour l’affichage des PDF,j’utilise native_pdf_view | Flutter Package , cet une librairie externe qui marche vraiment bien mais c’est vrai qu’il y a un certain de nombre de librairie qui ne sont pas fiable pour du long terme. Je vais me pencher dessus même si mon idée premier était qu’on puisse le modifier directement depuis l’app, je te remercie :slight_smile: