Question de NOOB désolé [codes erreur venant du fichier "ne pas toucher" ]

j’ai commencé le cours sur la prog en DART POO, depuis aujourd’hui, j’ai des messages d’erreur sur mon code mais aussi sur le code de maxime récupérer directement du github.
Je n’arrive pas à voir d’ou viens le pb car les codes erreur venant du fichier « ne pas toucher » que je ne touche pas bien sur".
J’ai spammé Maxime en lui envoyant un email également, [sorry], merci à tous pour le support.

Le problème proviens des valeurs NULL présente dans la partie user_input.dart du projet.

Que faire?
Merci à tous.

Bonjour,

Qu’elle est la version de Dart sur laquelle tu travailles? De ce que je vois, c’est un problème de Null Safety. A partir de la version 2.12 (si je ne me trompe pas) Dart prend en compte le Null Safety.
On peut changer la version dans pubspec.yaml. Essai de prendre la même version que Maxime dans ses cours.

Merci je vais voir de suite, l’update de dart c’est faite via VSCode.

En utilisant la fonction QuickFix de VSCode, cela fonctionne enfin, merci.

Bonjour Xavier,
aucun soucis ne t’inquiète pas :wink:
Il faut que tu prennes la version « null safety » du projet d’exercice, tu devrais le trouver sur le dépôt Github.
Voici la vidéo qui explique ce concept et où trouver le fichier : Versions de Dart et Gestion des valeurs nulles | Purple Giraffe

Happy coding!

1 J'aime